Aurora glass edit · Free shipping over $85 · Ice-violet drops

Microsoft Surface Pro 11 Copilot+PC - 13.0" Touch / Ultra 5 / 16GB / 256GB SSD / Win 11 Pro / Business Edition - Black Network Racks 2 • Secure Command Line

SKU: 20856461841
4.3
USD169.50 USD189.50 Aurora rate

Pay in 4 interest-free payments of $42.38 Learn more

Shipping Estimate
USA
  • USA
  • CAN

Ships within 48 hours · Estimated delivery Oct 31 - Nov 5

Description

Microsoft Surface Pro 11 Copilot+PC 13.0" Touch Ultra 5 16GB 256GB SSD Win 11 Pro Business Edition Black Network Racks 2 • Secure Command Line 2 • Secure Command Line Interface (CLI) management with SSHv1 SSHv2 • IP Port MAC based access control MIBs • MIB II (RFC1213) • Bridge MIB (RFC1493) • P Q Bridge MIB (RFC2674) • Radius Accounting Client MIB (RFC2620) • Radius Authentication Client MIB (RFC2618) • Remote Ping 0 Ports ‎1 Voltage ‎1 Volts Hardware Platform ‎Mac Operating System ‎mac os Are Batteries Included ‎No Lithium Battery Energy Content ‎4

Exchange/Return Notes
  • We offer a 30-day return/exchange service after receiving.
  • Final sale items are not eligible for returns or exchanges.
  • To process your return/exchange, please contact us at [email protected]
  • Please click here for more details>>> Return & Exchange Policy

You may also like

recommand products

{{{explore_related_edits_fragment}}}